Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

Le moteur de jeux Unity arrive sur Linux : des binaires expérimentaux sont disponibles

Le , par LittleWhite

48PARTAGES

11  0 
Unity arrive sur Linux. Pour le moment, ce ne sont que des binaires expérimentaux et vous devez vous attendre à rencontrer des bogues. De plus, il n'est pas encore certains que le moteur de jeux sera pleinement supporté sous Linux. En effet, cela dépend uniquement de l'engouement des testeurs et de leurs retours.


Quoiqu'il en soit, aujourd'hui il est possible de tester le moteur de jeux Unity sur Linux. Ces binaires reposent sur la version 5.1.0f3 et vous permettra d'exporter vos projets pour les plateformes suivantes :
  • Linux, Mac et Windows ;
  • WebGL ;
  • WebPlayer ;
  • Android ;
  • Tizen ;
  • SamsunTV.


Pour faire fonctionner Unity, il est recommandé d'avoir Ubuntu 12.04 (ou plus récent), en version 64 bits et une carte graphique récente. Il est aussi possible d'utiliser une autre distribution, grâce à l'installateur générique.
Vous pouvez télécharger les binaires en suivant ces liens :


Un forum spécifique a été ouvert pour récupérer vos témoignages. N'hésitez pas à faire part de vos expérimentations à la communauté de Developpez.com en répondant à cette discussion, par exemple. De plus, nous proposer de multiples ressources pour apprendre à utiliser le moteur.

Retrouvez toutes nos ressources sur Unity !

Votre opinion

Attendiez-vous ces binaires et une annonce liée à Linux ?
Comment voyez-vous cette annonce pour le monde du jeu vidéo sous Linux ? et pour le monde de Linux ?

Source

Billet officiel

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de CuShion
Futur Membre du Club https://www.developpez.com
Le 01/06/2019 à 2:30
Cool, étant donné que j'ai commencé avec Unity je trouve que c'est réjouissant de voir un autre application s'ajouter au store de Linux. Mais voilà, j'ai swich sur godot depuis le temps, je ne le regrette pas pour autant vu qu'il est open source, à un thème noir par defaut, ne prends pas des plombes pour démarer (en même temps, plus léger que godot tu meurt) et il possède un plus grand choix de langages de programmation ( C++, C#, Visual Scripting et Gdscript). Excusez-moi, je m'égare...
Et en ce qui concerne les mises à jour, c'est totalement du foutage de gueule. Bref le game design sur Linux a de bons jours devant lui
5  1 
Avatar de Garvelienn
Membre éprouvé https://www.developpez.com
Le 31/05/2019 à 15:38
Ce n'est pas trop tôt !!



<trolldi>Je vais enfin pouvoir travailler sur un vrai OS </trolldi>
3  2 
Avatar de Iradrille
Expert confirmé https://www.developpez.com
Le 27/08/2015 à 10:17
Citation Envoyé par LittleWhite Voir le message
Comment voyez-vous cette annonce pour le monde du jeu vidéo sous Linux ? et pour le monde de Linux ?
Il n'y à qu'une façon de voir ça, c'est une bonne nouvelle.

Les jeux créés avec Unity fonctionnent déjà sous Linux ? C'est l'éditeur qui n'était pas dispo sous Linux ?
0  0 
Avatar de LittleWhite
Responsable 2D/3D/Jeux https://www.developpez.com
Le 27/08/2015 à 10:40
Exactement. L'éditeur n'était pas disponible sous Linux (juste Windows et Mac OS X). Il était tout de même possible d'exporter ses projets et d'en faire des binaires Linux
0  0 
Avatar de Jarodd
Membre expérimenté https://www.developpez.com
Le 28/08/2015 à 11:10
Qu'est-ce qu'une « carte graphique récente » ? C'est la date d'achat qui fait tourner (ou pas) Unity ? Ou bien des spécs précises ?
0  0 
Avatar de LittleWhite
Responsable 2D/3D/Jeux https://www.developpez.com
Le 28/08/2015 à 14:09
Il n'y a pas de spécifications précises. Je dirais compatible OpenGL 3.3, mais là, j'avance sans vraiment savoir.
0  0 
Avatar de Zefling
Membre expert https://www.developpez.com
Le 30/08/2015 à 22:04
Installé pour voir et première chose, sous Debian ça s'installe sans soucis. Maintenant, je ne connais pas du tout le logiciel. Heureusement il y a quelques tuto ici.
0  0